No wireless Internet while using certain routers

Specific forum for all wireless related issues. Even if you have a wireless router, only post here if you have a question about issues with the wireless functionality of it. Questions about wireless access points, cards, hot-spots etc. are also welcome here.
Post Reply
Posts: 1
Joined: Fri Dec 19, 2014 6:20 am

No wireless Internet while using certain routers

Post by viabella » Fri Dec 19, 2014 6:42 am

I have an issue with internet connectivity. Every couple of minutes/Hours the internet stop working and I get little yellow icon on the wifi it says "no internet access". The only way to resolve it is to do "troubleshoot" from windows and it restarts the network adapter and recover the internet.
It's been always like that, ever since I purchase this laptop so I thought it is something with a bad Wi-Fi adapter but recently I connected to my neighbor's Wi-Fi and the problem is gone. Didn't happen even once so I assume it is something to do with my router settings. So I login to both routers page and I don't see any major difference with settings.
Can someone point me to what might be the problem? Or if you need more info just let me know what should I upload in order to solve it?
My router is from Comcast/Xfinity Arris TG862G
My neighbor's router is Belkin #F5D7234-4

I am using HP Envy m6 laptop with Win 8.1 installed including all updates.
network adapter- RALINK 5390R with driver number (which is the latest one according to Ralink website).
I tried installing all of windows updates including the wifi driver from Microsoft- didn't do any good.
Tried to replace the laptop to a new one form the same model- problem still happening.
While I am connected with LAN- Everything works perfect.

Thank you so much in advance,
Post Reply