Cannot access database

All errors or issues on the website/forums should be reported here and will be investigated. Support questions about how to use/access features not documented in the forum FAQ and discussion about the site forums are also welcome here, but please read this thread before posting such items.
Locked
User avatar
Steve
Ex RouterTech Team
Ex RouterTech Team
Posts: 980
Joined: Fri Jan 27, 2006 2:34 am

Cannot access database

Post by Steve » Sat Apr 22, 2006 11:09 am

Got the following for a couple of minutes @ approx 11:05 today


Warning: mysql_connect(): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /home/router/public_html/db/mysql4.php on line 48

Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in /home/router/public_html/db/mysql4.php on line 330

Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in /home/router/public_html/db/mysql4.php on line 331
phpBB : Critical Error

Could not connect to the database
He ached all over. It wasn't just that his brain was writing cheques that his body couldn't cash. It had gone beyond that. Now his feet were borrowing money that his legs hadn't got, and his back muscles were looking for loose change under the sofa cushions.
- Terry Pratchett

www.bliss.org.uk
User avatar
Martyn
Ex RouterTech Team
Ex RouterTech Team
Posts: 317
Joined: Wed Jan 25, 2006 11:19 pm
Location: Cheshire
Contact:

Post by Martyn » Sat Apr 22, 2006 1:56 pm

That's what you get when you use some fly-by-night hosting company :wink: :wink:
User avatar
Kieran
RouterTech Team
RouterTech Team
Posts: 2670
Joined: Fri Jan 20, 2006 11:30 am
Location: London
Contact:

Post by Kieran » Sat Apr 22, 2006 2:03 pm

We had a minor DoS attack that caused some services to go down, including MySQL. All affected services have been restarted and all is running well. The reason we were affected by this attack is still being investigated.
Kieran
"Indeed!"
Invaluable links: Forum Rules | Networking Guides | FAQ | Site Search | Forum Search <-- Use it or feel my wrath!
No support via PM, please ask your questions in the forum!
User avatar
Kieran
RouterTech Team
RouterTech Team
Posts: 2670
Joined: Fri Jan 20, 2006 11:30 am
Location: London
Contact:

Post by Kieran » Tue Apr 25, 2006 6:36 pm

Culprits were not traceable, but it all seemed to have quietened down pretty soon after. I am closing this for now, but if anyone finds more errors of this type, please PM me when the forum comes back up and let me know times, error messages etc.
Kieran
"Indeed!"
Invaluable links: Forum Rules | Networking Guides | FAQ | Site Search | Forum Search <-- Use it or feel my wrath!
No support via PM, please ask your questions in the forum!
Locked