Please help with bricked Pluscom router

All about firmwares for routers. Support for RouterTech firmwares is here too.
Andyxzyk
Novice
Novice
Posts: 18
Joined: Fri Mar 30, 2007 11:17 pm

Post by Andyxzyk » Sun Apr 01, 2007 9:01 pm

indeed, i agree. My next step will be the serial cable as soon as i can get the rs232 chip i will build one and monitor the output via a console session. You may be onto something regarding the reset button. It doesn't seem to be doing anything different when i do the factory reset.]
Still the exercise was well worth it cause i have learnt a lot and i hope that others who may have similar problems with this router will find this thread interesting.
thanks to everyone for participating and as far as i'm concerned we can consider this thread closed for now. I will report back if i ever have anything further useful to add, or better still, if i ever get it working again.
thanks.
Andy
User avatar
biro
RouterTech Team
RouterTech Team
Posts: 1274
Joined: Wed Jan 25, 2006 10:03 pm
Location: Letchworth Garden City, ENGLAND
Contact:

Post by biro » Mon Apr 02, 2007 12:00 am

One thing to remember is the 'reset' button is under software control, if the router fails to boot properly then the code for the reset button probably isn't getting loaded !
ImageImageImage
All my posts on RouterTech.org are Copyright RouterTech.org
G'Day Laura
willshep
Regular
Regular
Posts: 46
Joined: Tue Mar 27, 2007 1:45 pm

Post by willshep » Mon Apr 02, 2007 10:25 am

I've recently done all this and survived having bought the same Pluscom - I don't know whether you've done this - but all your symptoms seem very similar to mine - all I found was that I hadn't realised exactly how long your supposed to hold in the reset button.

So - that is - turn on the router - wait a bit - then push it in and hold it for at least 15 seconds - I found that after this time the lights all flashed on then off again. Afterwards it was perfect.

I must say though that i didn't change any internal variables at all - I found that PcApp 2.3 worked best for me with this router too and not PCTool becuase the router is PSP based not Adam2.

See what happens.. W.
Andyxzyk
Novice
Novice
Posts: 18
Joined: Fri Mar 30, 2007 11:17 pm

SUCCESS !

Post by Andyxzyk » Fri Apr 06, 2007 3:36 am

Just goes to show the power of forums and the net community.
I tried everything i could think of with this router, and although i learnt a lot in the process i never could unbrick it. But after my friend for life (Will -another member on this forum) PMed me his router's env settings I put them in and loaded RT 2.2 (not holding out much hope as I had tried it load of times before with no success) and lo and behold after a factory reset it sprung back to life.
I am posting below the env settings which i believe unbricked my router, hoping it can help others with pluscom routers (AR-7200).
So a big thanks to all for their suggestions and a very special thanks to Will.
-----------------env settings below -----------------------------
BUILD_OPS 0x301
bootloaderVersion 1.4.0.4
IPA 192.168.1.1
mtd2 0x90000000,0x90010000
mtd3 0x90010000,0x90020000
mtd1 0x90020090,0x90097000
mtd0 0x90097000,0x90200000
MAC_PORT 0
MEMSZ 0x00800000
FLASHSZ 0x00200000
MODETTY0 9600,n,8,1,hw
MODETTY1 9600,n,8,1,hw
CPUFREQ 211968000
MIPSFREQ 211968000
SYSFREQ 105984000
PROMPT (psbl)
mtd4 0x90020000,0x90200000
BOOTCFG m:f:"mtd1"
----------------end of env settings--------------------------------------
User avatar
thechief
RouterTech Team
RouterTech Team
Posts: 12066
Joined: Wed Feb 01, 2006 10:22 pm
Location: England, the Centre of Africa
Contact:

Post by thechief » Fri Apr 06, 2007 8:05 am

Excellent :)
The Chief: :afro: Be sure to read the Firmware FAQ and do a Forum Search before posting!
No support via PM. Ask all questions on the open forum.
coder
Novice
Novice
Posts: 24
Joined: Sun Apr 15, 2007 8:32 am

same problem on a PTI-8411G

Post by coder » Sun Apr 15, 2007 11:24 am

Thanks for the info, unfortunately i didnt finish reading this whole thread thus ended up spending a couple of hours to get to

BOOTCFG m:f:"mtd1"

afterwhich my serial console came to life with the linux boot debug info.

anyone running in to this problem should also note that when flashing a new firmware (rather, copying it via PCAPP2.3 or FTP) that mtd4 (provided that it is a fs+kernel .img) should be set correctly. the 29LV160CBTC-70G (mentioned here) is a 16Megabit (2Mbyte) chip. thus

mtd4 0x90020000,0x90200000

but some manufacturers (http://www.paradigm.com.tw) use 29LV320CBTC-70G . essentially doubling (32Megabits or 4Mbyte)the flash memory. this has to be addressed by varying mtd4 to

mtd4 0x90020000,0x90400000


this one of the main problems i had with getting the firmware in to my router. (there was a notice regarding some magic as well :D )
Post Reply