RouterTech Firmware v2.3 released

Latest news from RouterTech
archefcj
Newbie
Newbie
Posts: 1
Joined: Tue Nov 20, 2007 11:15 am

Post by archefcj » Wed Nov 21, 2007 10:28 am

Just flashed this onto my Etec PTI-845G router and it works a treat. Many thanks
User avatar
jimp
Novice
Novice
Posts: 24
Joined: Thu Nov 01, 2007 7:02 pm

Impressive!

Post by jimp » Wed Nov 21, 2007 7:21 pm

I was suffering form the dreaded Linux DNS problem (lots of mention of this in the forums here), and thought I'd give this a go with my ebuyer GART2-4112 on Pipex. Not only has the problem gone away, but other things have improved. Sourceforge works much faster, and I've been able to make the move to Linux on my main machine. Thanks guys, an excellent job!
shevans
Novice
Novice
Posts: 17
Joined: Tue Nov 20, 2007 8:03 pm

Post by shevans » Sat Nov 24, 2007 8:29 pm

So I flashed my Safecom-54108, it worked a treat and now the router is actually worth holding onto.

THANK YOU TEAM!!
User avatar
sho
Newbie
Newbie
Posts: 2
Joined: Sat Nov 24, 2007 8:10 pm

Post by sho » Sat Nov 24, 2007 11:52 pm

Successful flash of BeWan 700G ADSL2+.

Thank you :D
User avatar
thechief
RouterTech Team
RouterTech Team
Posts: 12064
Joined: Wed Feb 01, 2006 10:22 pm
Location: England, the Centre of Africa
Contact:

Post by thechief » Sun Nov 25, 2007 4:14 pm

Many thanks, shevans and sho :)
The Chief: :afro: Be sure to read the Firmware FAQ and do a Forum Search before posting!
No support via PM. Ask all questions on the open forum.
bighun
Newbie
Newbie
Posts: 8
Joined: Sat Dec 01, 2007 2:56 pm

swamr-54125

Post by bighun » Sun Dec 02, 2007 4:22 pm

jusst flashed my safecom swamr-54125 to this firmware so far it is excellent faster than the safecom one
User avatar
thechief
RouterTech Team
RouterTech Team
Posts: 12064
Joined: Wed Feb 01, 2006 10:22 pm
Location: England, the Centre of Africa
Contact:

Post by thechief » Sun Dec 02, 2007 4:27 pm

Thanks :)
The Chief: :afro: Be sure to read the Firmware FAQ and do a Forum Search before posting!
No support via PM. Ask all questions on the open forum.
Cat007
Novice
Novice
Posts: 18
Joined: Thu Dec 13, 2007 7:57 am

Post by Cat007 » Fri Dec 14, 2007 12:33 pm

Some problems with 2.3 release.
I loaded 2.3 to DLink G604T... Connect and disconnect procedures performed correctly and stable... But...

Some time after rebooting using button "Restart router" from Web interface my router goes to down and after that i can see onlu Power lamp and no others (it was happend 2 times)... Router dont answer to Web connections...

Router can be returnet back to normal state only after reloading.

But no such things after gold restart (turn power off and on)...

What you can advice me?

Thanks in advance
Konstantin
User avatar
thechief
RouterTech Team
RouterTech Team
Posts: 12064
Joined: Wed Feb 01, 2006 10:22 pm
Location: England, the Centre of Africa
Contact:

Post by thechief » Fri Dec 14, 2007 1:02 pm

Which firmware image did you use?
The Chief: :afro: Be sure to read the Firmware FAQ and do a Forum Search before posting!
No support via PM. Ask all questions on the open forum.
Cat007
Novice
Novice
Posts: 18
Joined: Thu Dec 13, 2007 7:57 am

Post by Cat007 » Fri Dec 14, 2007 1:07 pm

thechief wrote:Which firmware image did you use?
ZIP file - RouterTech.3.6.0D.DSL-G604T.zip
IMG file

RouterTech_3.6.0D_20070604_2.30_AR7WRD_Adam2_ATMEL_firmware.upgrade.img

as per recomendations...
User avatar
thechief
RouterTech Team
RouterTech Team
Posts: 12064
Joined: Wed Feb 01, 2006 10:22 pm
Location: England, the Centre of Africa
Contact:

Post by thechief » Fri Dec 14, 2007 1:14 pm

Can you post a copy of the system diagnostics (after removing all personal/sensitive information)?
The Chief: :afro: Be sure to read the Firmware FAQ and do a Forum Search before posting!
No support via PM. Ask all questions on the open forum.
Cat007
Novice
Novice
Posts: 18
Joined: Thu Dec 13, 2007 7:57 am

Post by Cat007 » Fri Dec 14, 2007 1:18 pm

thechief wrote:Can you post a copy of the system diagnostics (after removing all personal/sensitive information)?
I can do it only after reloading firmware my router... because now it is dont answer and i cant open Web interface for getting this info...


Will put all info some later... (because router was down when i rebooted it over Internet ... and now router at home)...
KevinR
Regular
Regular
Posts: 95
Joined: Sat Jul 14, 2007 8:51 pm

Post by KevinR » Fri Dec 14, 2007 4:10 pm

I've had good luck with DarkWolf's variant of the routertech software on a dsl-g604t. It may simply be that his version of the upload (ie. pctool or config parameters) works better on these routers.

Mine killed itself on the first upload and then I used the dead router recovery mode and that flashed ok. Mine was going from v1 firmware which was a big jump.

Not to detract from the Chief's original efforts but darkwolf is here: http://darkwolf.altervista.org/index.php.
Cat007
Novice
Novice
Posts: 18
Joined: Thu Dec 13, 2007 7:57 am

Post by Cat007 » Fri Dec 14, 2007 6:38 pm

thechief wrote:Can you post a copy of the system diagnostics (after removing all personal/sensitive information)?
Please find enclosed system diagnostics from my router :
(i was reload router with 2.3 release and only after reloading i can read diagnostics data)

ROUTERTECH SYSTEM DIAGNOSTICS

Operating system version
Linux version 2.4.17_mvl21-malta-mips_fp_le (root@localhost.localdomain) () #1 Mon Jun 4 17:31:10 BST 2007

Firmware version information
BUILD=RouterTech_3.6.0D_20070604_2.30
VERSION=3.6.0D-RouterTech-Adam2
BOARD=AR7WRD
FSSTAMP=20070604173357

Wireless version information
5.7.0.6, 1/4/2005

PSP version information

Linux OS DSL-PSPOhioL version 4.5.0.5 Best and Final on BasePSP Version 5.7.6.12 Jun 4 2007 17:32:24
Avalanche SOC Version: 0x20005 operating in cached, write back, write allocate mode
Cpu Frequency:150 MHZ
System Bus frequency: 125 MHZ


Driver version information
Texas Instruments CPMAC driver version: 1.5
Texas Instruments CPMAC HAL version: CPMAC 01.07.08 Jun 4 2007 17:31:22
ATM Driver version:[6.01.03.00]
DSL HAL version: [6.01.02.00]
DSP Datapump version: [6.02.01.00] Annex A
SAR HAL version: [01.07.2c]
PDSP Firmware version:[0.54]
Chipset ID: [7300/7300A]

TI Linux LED Driver Version 0.1

Modem Modulation Information
NO_MODE 0x0
ADSL_G.dmt 0x3
ADSL_G.lite 0x4
ADSL_G.dmt.bis 0x8
ADSL_G.dmt.bis_DELT 0x9
ADSL_2plus 0x10
ADSL_2plus_DELT 0x11
ADSL_re-adsl 0x20
ADSL_re-adsl_DELT 0x21
ADSL_ANSI_T1.413 0x2
MULTI_MODE 0x1
ADSL_G.dmt.bis_AnxI 0x0
ADSL_G.dmt.bis_AnxJ 0x0
ADSL_G.dmt.bis_AnxM 0x400
ADSL_2plus_AnxI 0x0
ADSL_2plus_AnxJ 0x0
ADSL_2plus_AnxM 0x2000
G.shdsl 0x0
IDSL 0x0
HDSL 0x0
SDSL 0x0
VDSL 0x0

System environment (/proc/sys/dev/adam2/environment)
memsize 0x01000000
flashsize 0x00400000
modetty0 38400,n,8,1,hw
modetty1 38400,n,8,1,hw
bootserport tty0
cpufrequency 150000000
sysfrequency 125000000
bootloaderVersion 0.22.02
Adam2_Release 0.22.02_b04_Mar 10 2005
ProductID AR7RD
HWRevision Unknown
SerialNumber none
my_ipaddress 192.168.1.1
prompt Adam2_AR7RD
firstfreeaddress 0x9401d888
req_fullrate_freq 125000000
maca xx:xx:xx:xx
mtd0 0x90094000,0x903f0000
mtd1 0x90010090,0x90094000
mtd2 0x90000000,0x90010000
mtd3 0x903f0000,0x90400000
mtd4 0x90010000,0x903f0000
led_conf led.g604t
autoload 1
autoload_timeout 5
StaticBuffer 120
vcc_encaps0 0.0
vcc_encaps1 0.0
vcc_encaps2 0.0
vcc_encaps3 0.0
vcc_encaps4 0.0
vcc_encaps5 0.0
vcc_encaps6 0.0
vcc_encaps7 0.0
modulation 0x1
connection0 0x3702


CPU information
processor : 0
cpu model : MIPS 4KEc V4.8
BogoMIPS : 149.91
wait instruction : no
microsecond timers : yes
extra interrupt vector : yes
hardware watchpoint : yes
VCED exceptions : not available
VCEI exceptions : not available

Memory information
total: used: free: shared: buffers: cached:
Mem: 14446592 14049280 397312 0 1126400 4931584
Swap: 0 0 0
MemTotal: 14108 kB
MemFree: 388 kB
MemShared: 0 kB
Buffers: 1100 kB
Cached: 4816 kB
SwapCached: 0 kB
Active: 1892 kB
Inactive: 5832 kB
HighTotal: 0 kB
HighFree: 0 kB
LowTotal: 14108 kB
LowFree: 388 kB
SwapTotal: 0 kB
SwapFree: 0 kB

Mount points
/dev/mtdblock/0 / squashfs ro 0 0
none /dev devfs rw 0 0
proc /proc proc rw 0 0
ramfs /var ramfs rw 0 0

Filesystems
nodev rootfs
nodev bdev
nodev proc
nodev sockfs
nodev tmpfs
nodev shm
nodev pipefs
nodev ramfs
minix
nodev devfs
squashfs
nodev cifs

MTD
dev: size erasesize name
mtd0: 0035c000 00010000 "mtd0"
mtd1: 00083f70 00010000 "mtd1"
mtd2: 00010000 00002000 "mtd2"
mtd3: 00010000 00010000 "mtd3"
mtd4: 003e0000 00010000 "mtd4"

Kernel modules
tiap 708536 1
avalanche_usb 63296 1
tiatm 133520 1

Interrupts
7: 50904 R4000 timer/counter [MIPS interrupt]
8: 0 unified secondary [hw0 (Avalanche Primary)]
15: 205 serial [hw0 (Avalanche Primary)]
23: 3965 + SAR [hw0 (Avalanche Primary)]
29: 6461 vlynq0 [hw0 (Avalanche Primary)]
32: 1 + USB [hw0 (Avalanche Primary)]
41: 47 + Cpmac Driver [hw0 (Avalanche Primary)]
47: 44 + DSL [hw0 (Avalanche Primary)]
80: 6459 TNETW1130 [hw0 (Low Vlynq)]

Devices
Character devices:
1 mem
2 pty/m%d
3 pty/s%d
4 tts/%d
5 cua/%d
10 misc
108 ppp
128 ptm
136 pts/%d
162 raw

Block devices:
31 mtdblock

Processes
PID Uid VmSize Stat Command
1 root 1416 S init
2 root S [keventd]
3 root S [ksoftirqd_CPU0]
4 root S [kswapd]
5 root S [bdflush]
6 root S [kupdated]
7 root S [cifsoplockd]
8 root S [mtdblockd]
92 root 2156 S /usr/bin/cm_pc
94 root 1188 S /usr/sbin/thttpd -d /usr/www -u root -p 80 -c /cgi-b
99 root 3824 S /usr/bin/cm_logic -m /dev/ticfg -c /etc/config.xml
137 root 636 S /sbin/dproxy -c /etc/resolv.conf -d
138 root 996 S /usr/sbin/wlan/wpa_authenticator
201 root 768 S crond -b
277 root 1416 S init
300 root 2348 S /usr/sbin/pppd plugin pppoe wbif0 user xx:xx:xx:xx pa
330 root 920 S /sbin/msntp -r 2 -t 5 -p 30 -s time-a.nist.gov time-
379 root 1420 S /bin/sh diagnostics.cgi
380 root 1188 S /usr/sbin/thttpd -d /usr/www -u root -p 80 -c /cgi-b
393 root 612 S /usr/local/bin/diagnostics
394 root 1420 S sh -c /usr/local/bin/diagnostics.sh
395 root 1428 S /bin/sh /usr/local/bin/diagnostics.sh
451 root 1416 R /bin/ps aux

ADSL Modem information

AR7 DSL Modem Statistics:
--------------------------------
[DSL Modem Stats]
US Connection Rate: 128 DS Connection Rate: 256
DS Line Attenuation: 25 DS Margin: 31
US Line Attenuation: 10 US Margin: 28
US Payload : 264000 DS Payload: 762048
US Superframe Cnt : 27582 DS Superframe Cnt: 27582
US Transmit Power : 5 DS Transmit Power: 14
LOS errors: 0 SEF errors: 0
Errored Seconds: 0 Severely Err Secs: 0
Frame mode: 3 Max Frame mode: 0
Trained Path: 1 US Peak Cell Rate: 301
Trained Mode: 3 Selected Mode: 1
ATUC Vendor Code: 4753504E ATUC Revision: 1
Hybrid Selected: 1 Trellis: 1
Showtime Count: 1 DS Max Attainable Bit Rate: 9248 kbps
BitSwap: 1 US Max Attainable Bit Rate: n/a
Annex: AnxA psd_mask_qualifier: 0x0000
ATUC ghsVid: 00 b5 47 53 50 4e 00 04
T1413Vid: 00 00 T1413Rev: 00 VendorRev: 00
ATUR ghsVid: b5 00 54 53 54 43 00 00
T1413Vid: 00 00 T1413Rev: 00 VendorRev: 00

[Upstream (TX) Interleave path]
CRC: 1 FEC: 0 NCD: 0
LCD: 0 HEC: 68

[Downstream (RX) Interleave path]
CRC: 0 FEC: 0 NCD: 0
LCD: 0 HEC: 0

[Upstream (TX) Fast path]
CRC: 0 FEC: 0 NCD: 1
LCD: 0 HEC: 0

[Downstream (RX) Fast path]
CRC: 0 FEC: 0 NCD: 0
LCD: 0 HEC: 0

[ATM Stats]
[Upstream/TX]
Good Cell Cnt: 5500
Idle Cell Cnt: 136052


[Downstream/RX)]
Good Cell Cnt: 15876
Idle Cell Cnt: 267211
Bad Hec Cell Cnt: 0
Overflow Dropped Cell Cnt: 0

[SAR AAL5 Stats]
Tx PDU's: 1455
Rx PDU's: 2501
Tx Total Bytes: 228955
Rx Total Bytes: 701454
Tx Total Error Counts: 0
Rx Total Error Counts: 0


[OAM Stats]
Near End F5 Loop Back Count: 0
Near End F4 Loop Back Count: 0
Far End F5 Loop Back Count: 0
Far End F4 Loop Back Count: 0
SAR OAM Ping Response Drop Count=15

Network statistics
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 *:www *:* LISTEN
tcp 0 0 *:ftp *:* LISTEN
tcp 0 0 *:ssh *:* LISTEN
tcp 0 0 *:telnet *:* LISTEN
tcp 0 0 10.0.0.98:www 10.0.0.93:2405 TIME_WAIT
tcp 0 0 10.0.0.98:www 10.0.0.93:2401 TIME_WAIT
tcp 0 564 10.0.0.98:www 10.0.0.93:2409 ESTABLISHED
tcp 0 0 10.0.0.98:www 10.0.0.93:2395 TIME_WAIT
tcp 0 0 10.0.0.98:www 10.0.0.93:2406 TIME_WAIT
tcp 0 0 10.0.0.98:www 10.0.0.93:2402 TIME_WAIT
tcp 0 0 10.0.0.98:www 10.0.0.93:2408 TIME_WAIT
udp 0 0 *:1812 *:*
udp 0 0 *:domain *:*
udp 0 0 *:tftp *:*
Active UNIX domain sockets (servers and established)
Proto RefCnt Flags Type State I-Node Path
unix 5 [ ] DGRAM 174 /dev/log
unix 2 [ ] DGRAM 176 /dev/klog
unix 2 [ ] DGRAM 135 /var/tmp/cm_pc.ctl
unix 2 [ ] DGRAM 149 /var/tmp/cm_logic.ctl
unix 2 [ ] DGRAM 491
unix 2 [ ] DGRAM 445
unix 2 [ ] DGRAM 288
unix 2 [ ] STREAM 121
unix 2 [ ] DGRAM 120

Im hope to your help !!!
thaks in advance
brg
Konstanti

Edit: some things blanked out by thechief
Cat007
Novice
Novice
Posts: 18
Joined: Thu Dec 13, 2007 7:57 am

Post by Cat007 » Fri Dec 14, 2007 6:45 pm

KevinR wrote:I've had good luck with DarkWolf's variant of the routertech software on a dsl-g604t. It may simply be that his version of the upload (ie. pctool or config parameters) works better on these routers.

Mine killed itself on the first upload and then I used the dead router recovery mode and that flashed ok. Mine was going from v1 firmware which was a big jump.

Not to detract from the Chief's original efforts but darkwolf is here: http://darkwolf.altervista.org/index.php.
Thanx for your information... i heared about DarkWolf's FW from one of the russian web site... but i dont use it.....of course i will try it...
Locked