Aztech DSL 605EW (Single Antenna)

Talk about anything you like here: as long as it's technical, doesn't fit into the other categories and is within the rules. Questions and discussions about operating systems, programming, websites, hosting, ADSL etc. are particularly welcome here.
hashir
Novice
Novice
Posts: 22
Joined: Thu Jan 13, 2011 11:46 pm

Re: Aztech DSL 605EW (Single Antenna)

Post by hashir » Sun Feb 13, 2011 8:04 pm

Sep 16 15:27:55 2002: out of memory exiting
Sep 16 15:27:55 2002: manager_get_defaults - !node
Sep 16 15:27:55 2002: out of memory exiting


This is only what there in the system log of this firmware.
hashir
Novice
Novice
Posts: 22
Joined: Thu Jan 13, 2011 11:46 pm

Re: Aztech DSL 605EW (Single Antenna)

Post by hashir » Sun Feb 13, 2011 8:13 pm

I restarted the modem..NO I have the below info in system log

Sep 8 12:00:53 2002: Bootloader environment variable WLAN_EEPROM0 is not set!!!!!!!!
Sep 8 12:00:53 2002: Read EEPROM failed
Sep 8 12:00:53 2002: Bootloader environment variable WLAN_EEPROM0 is not set!!!!!!!!
Sep 8 12:00:53 2002: Read EEPROM failed
Sep 8 12:00:53 2002: Error: Failed to get a valid EEPROM Image. AP is DOWN
Sep 8 12:00:53 2002: NVS_TFTP_LOAD is enabled to download the correct EEPROM image during next boot. Set TFTP Server Address using IPA_SVR env variable
Sep 8 12:00:53 2002: AP Releasing Lock
Sep 8 12:00:53 2002: local IP address 86.97.52.102
Sep 8 12:00:53 2002: remote IP address 213.42.8.53
Sep 8 12:00:53 2002: primary DNS address 213.42.20.20
Sep 8 12:00:53 2002: secondary DNS address 195.229.241.222
Sep 8 12:00:53 2002: Default Asymmetric MTU for wlan0 1500
Sep 8 12:00:53 2002: if=wlan0, event=5
Sep 8 12:00:53 2002: Default Asymmetric MTU for wlan1 1500
Sep 8 12:00:53 2002: if=wlan1, event=5
Sep 8 12:00:53 2002: Default Asymmetric MTU for wlan2 1500
Sep 8 12:00:53 2002: if=wlan2, event=5
Sep 8 12:00:53 2002: Default Asymmetric MTU for wlan3 1500
Sep 8 12:00:53 2002: if=wlan3, event=5
Sep 8 12:00:53 2002: Default Asymmetric MTU for wdsup0 1500
Sep 8 12:00:53 2002: Default Asymmetric MTU for wdsdw0 1500
Sep 8 12:00:53 2002: Default Asymmetric MTU for wdsdw1 1500
Sep 8 12:00:53 2002: Default Asymmetric MTU for wdsdw2 1500
Sep 8 12:00:53 2002: Default Asymmetric MTU for wdsdw3 1500
Sep 8 12:00:53 2002: starting cleanup:
Sep 8 12:00:53 2002: if=wlan0, event=6
Sep 8 12:00:53 2002: if=wlan1, event=6
Sep 8 12:00:53 2002: if=wlan2, event=6
Sep 8 12:00:53 2002: if=wlan3, event=6
Sep 8 12:00:53 2002: cleanup finish succesfully, good-bye.
Sep 8 12:00:53 2002: DSL Carrier is down
Sep 8 12:00:53 2002: manager_get_defaults - !node
User avatar
thechief
RouterTech Team
RouterTech Team
Posts: 12066
Joined: Wed Feb 01, 2006 10:22 pm
Location: England, the Centre of Africa
Contact:

Re: Aztech DSL 605EW (Single Antenna)

Post by thechief » Sun Feb 13, 2011 8:17 pm

I see. In which case, there is no easy way to get your wireless back. If you are willing to get your hands dirty, then you need to save the following into a text file

Code: Select all

setenv NVS_TFTP_LOAD 0
setenv WLAN_HWADDR0 00:12:0E:75:00:7F
setenv wan_br_mac 00:12:0E:75:00:7F
unsetenv WLAN_EEPROM0
unsetenv WLAN_EEPROM1
unsetenv WLAN_EEPROM2
unsetenv WLAN_EEPROM3
unsetenv WLAN_EEPROM4
unsetenv WLAN_EEPROM5
unsetenv WLAN_EEPROM6
unsetenv WLAN_EEPROM7
unsetenv WLAN_EEPROM8
unsetenv WLAN_EEPROM9
unsetenv WLAN_EEPROM10
unsetenv WLAN_EEPROM11
unsetenv WLAN_EEPROM12
unsetenv WLAN_EEPROM13
unsetenv WLAN_EEPROM14
setenv WLAN_EEPROM0 021156041B06001200000601095612000000010D56A9000000026D547F00750E
setenv WLAN_EEPROM1 12000000013984000100000101854C1068900105850600100001298507000000
setenv WLAN_EEPROM2 01C1850000300001C585000000000111850000FFFF0115850000F0FF01A58500
setenv WLAN_EEPROM3 8000000109850000800201010C03000000012184000000800181851D00030001
setenv WLAN_EEPROM4 55090100000001E5580200000001F1580800000001D5581000000001B1580400
setenv WLAN_EEPROM5 0000000000000000000C00C300FE0008011401260144014D014F0165019F01AF
setenv WLAN_EEPROM6 01B70101390000110004010101000501060002010201021E000A000205020411
setenv WLAN_EEPROM7 2244030610203031324004095449204143583130300507544920546573740108
setenv WLAN_EEPROM8 0D150EFD9D5C014F0502000036006D00A600E5000404441016004510F903185A
setenv WLAN_EEPROM9 4000145A2000020E0801E6000A0188026E00A30185095000F9000A01C1026E00
setenv WLAN_EEPROM10 A10185090107100000400000010000050400010100000000FFFFFFFFFDFDFDFD
setenv WLAN_EEPROM11 FBF4F4F4F40E0409090909090909090909090909090909090909090909090909
setenv WLAN_EEPROM12 090909090909090909090909090909090909090909090909090909090909090E
setenv WLAN_EEPROM13 0100000000000000000000000000000302A318A3180700012000000000000000
setenv WLAN_EEPROM14 00000000000000000000000000000000000000000000000000
Then run the text file as a script with the PCTool. Check our firmware FAQ for links to that and instructions on how to use it. Then reboot the router, and go straight to the System log. It will complain about something - but in that complaint should be the TNETW ID.
The Chief: :afro: Be sure to read the Firmware FAQ and do a Forum Search before posting!
No support via PM. Ask all questions on the open forum.
hashir
Novice
Novice
Posts: 22
Joined: Thu Jan 13, 2011 11:46 pm

Re: Aztech DSL 605EW (Single Antenna)

Post by hashir » Sun Feb 13, 2011 8:44 pm

Sep 8 12:01:40 2002: Default Asymmetric MTU for wdsdw3 1500
Sep 8 12:01:40 2002: Getting WLAN EEPROM image ...
Sep 8 12:01:40 2002: EEPROM len 448
Sep 8 12:01:40 2002: Failed to get DIE ID from wlan driver. Cannot validate EEPROM Image
Sep 8 12:01:40 2002: EEPROM len 448
Sep 8 12:01:40 2002: Failed to get DIE ID from wlan driver. Cannot validate EEPROM Image
Sep 8 12:01:40 2002: EEPROM len 448
Sep 8 12:01:40 2002: Failed to get DIE ID from wlan driver. Cannot validate EEPROM Image
Sep 8 12:01:40 2002: Error: Failed to get a valid EEPROM Image. AP is DOWN
Sep 8 12:01:40 2002: NVS_TFTP_LOAD is enabled to download the correct EEPROM image during next boot. Set TFTP Server Address using IPA_SVR env variable
Sep 8 12:01:40 2002: AP Releasing Lock
Sep 8 12:01:40 2002: PPPoE Connect with IP Address 92.98.112.73
Sep 8 12:01:40 2002: PPPoE Connection Successfully Established
Sep 8 12:01:40 2002: sys_send_event - pppoe up
Sep 8 12:01:40 2002: PPPoE Connect with Gateway IP Address: 213.42.8.53
Sep 8 12:01:40 2002: local IP address 92.98.112.73
Sep 8 12:01:40 2002: remote IP address 213.42.8.53
Sep 8 12:01:40 2002: primary DNS address 213.42.20.20
Sep 8 12:01:40 2002: secondary DNS address 195.229.241.222
Sep 8 12:01:40 2002: Could not find the WLAN device configuration for instance 0
Sep 8 12:01:40 2002: Error reading TNETW mem map.
Sep 8 12:01:40 2002: Could not find the WLAN device configuration for instance 0
Sep 8 12:01:40 2002: Error reading TNETW mem map.
Sep 8 12:01:40 2002: Could not find the WLAN device configuration for instance 0
Sep 8 12:01:40 2002: Error reading TNETW mem map.
Sep 8 12:01:40 2002: starting cleanup:
Sep 8 12:01:40 2002: if=wlan0, event=6
Sep 8 12:01:40 2002: if=wlan1, event=6
Sep 8 12:01:40 2002: if=wlan2, event=6
Sep 8 12:01:40 2002: if=wlan3, event=6
Sep 8 12:01:40 2002: cleanup finish succesfully, good-bye.
Sep 8 12:01:40 2002: manager_get_defaults - !node
User avatar
thechief
RouterTech Team
RouterTech Team
Posts: 12066
Joined: Wed Feb 01, 2006 10:22 pm
Location: England, the Centre of Africa
Contact:

Re: Aztech DSL 605EW (Single Antenna)

Post by thechief » Sun Feb 13, 2011 8:49 pm

Ok, you might need to add these as to the text file

Code: Select all

setenv IPA_SVR 192.168.1.2
setenv DSL_BIT_TMODE 1
setenv DSL_UPG_DONE 1
And then run the text file as a script again (with the PCTool).
The Chief: :afro: Be sure to read the Firmware FAQ and do a Forum Search before posting!
No support via PM. Ask all questions on the open forum.
hashir
Novice
Novice
Posts: 22
Joined: Thu Jan 13, 2011 11:46 pm

Re: Aztech DSL 605EW (Single Antenna)

Post by hashir » Sun Feb 13, 2011 9:03 pm

Sep 8 12:01:34 2002: Default Asymmetric MTU for wdsdw3 1500
Sep 8 12:01:34 2002: local IP address 92.98.26.216
Sep 8 12:01:34 2002: PPPoE Connect with IP Address 92.98.26.216
Sep 8 12:01:34 2002: PPPoE Connection Successfully Established
Sep 8 12:01:34 2002: sys_send_event - pppoe up
Sep 8 12:01:34 2002: PPPoE Connect with Gateway IP Address: 213.42.8.53
Sep 8 12:01:34 2002: Getting WLAN EEPROM image ...
Sep 8 12:01:34 2002: EEPROM len 448
Sep 8 12:01:34 2002: Failed to get DIE ID from wlan driver. Cannot validate EEPROM Image
Sep 8 12:01:34 2002: EEPROM len 448
Sep 8 12:01:34 2002: Failed to get DIE ID from wlan driver. Cannot validate EEPROM Image
Sep 8 12:01:34 2002: EEPROM len 448
Sep 8 12:01:34 2002: Failed to get DIE ID from wlan driver. Cannot validate EEPROM Image
Sep 8 12:01:34 2002: Error: Failed to get a valid EEPROM Image. AP is DOWN
Sep 8 12:01:34 2002: NVS_TFTP_LOAD is enabled to download the correct EEPROM image during next boot. Set TFTP Server Address using IPA_SVR env variable
Sep 8 12:01:34 2002: AP Releasing Lock
Sep 8 12:01:34 2002: remote IP address 213.42.8.53
Sep 8 12:01:34 2002: primary DNS address 213.42.20.20
Sep 8 12:01:34 2002: secondary DNS address 195.229.241.222
Sep 8 12:01:34 2002: Could not find the WLAN device configuration for instance 0
Sep 8 12:01:34 2002: Error reading TNETW mem map.
Sep 8 12:01:34 2002: Could not find the WLAN device configuration for instance 0
Sep 8 12:01:34 2002: Error reading TNETW mem map.
Sep 8 12:01:34 2002: Could not find the WLAN device configuration for instance 0
Sep 8 12:01:34 2002: Error reading TNETW mem map.
Sep 8 12:01:34 2002: starting cleanup:
Sep 8 12:01:34 2002: if=wlan0, event=6
Sep 8 12:01:34 2002: if=wlan1, event=6
Sep 8 12:01:34 2002: if=wlan2, event=6
Sep 8 12:01:34 2002: if=wlan3, event=6
Sep 8 12:01:34 2002: cleanup finish succesfully, good-bye.
Sep 8 12:01:34 2002: manager_get_defaults - !node
User avatar
thechief
RouterTech Team
RouterTech Team
Posts: 12066
Joined: Wed Feb 01, 2006 10:22 pm
Location: England, the Centre of Africa
Contact:

Re: Aztech DSL 605EW (Single Antenna)

Post by thechief » Sun Feb 13, 2011 9:42 pm

Post the current contents of the environment.
The Chief: :afro: Be sure to read the Firmware FAQ and do a Forum Search before posting!
No support via PM. Ask all questions on the open forum.
hashir
Novice
Novice
Posts: 22
Joined: Thu Jan 13, 2011 11:46 pm

Re: Aztech DSL 605EW (Single Antenna)

Post by hashir » Mon Feb 14, 2011 4:41 pm

Router Upgrade Check 1.4.1 14/02/2011 19:37:35
Router IP: 192.168.1.1
CLI is needed
Description: Aztech DSL 605EW
Board type: AR7WRD
Product ID: AR7WRD
Bootloader: psbl
RAM 16.0 MB
Flash (ROM) 4.0 MB
ADAM2: No
No default env: No
Linux version: 2.4.17_mvl21-malta-mips_fp_le
Firmware build: 090409
Firmware version: 3.7.0
Firmware stamp: 20090409103258
CPU: MIPS 4KEc V4.8
DSP: 6.02.00.-72
Annex: A
/proc/wlan: No
/usr/sbin/wlan: Yes
TIAP: No
TNETW: No
Wireless: Yes
WIFI chip: Not TNETW1130
WIFI chip conf: No
Ports: 4
Ports (according to router): N/A
Marvell (or Marvell like): No
NSP: 3.7.0
Manufacturers: Abocom
RNDIS: Telogy Networks Inc
HRNDIS: Telogy Networks Inc
WARNING
Cannot confirm the model number of the wireless chip.
The wireless access point (AP) may be disabled - ensure it is enabled and then run this program again.
WARNING
Your router does not have a Marvell switch and so your switch is not supported.
Your Ethernet ports may or may not function correctly with a RouterTech firmware.

Select an AR7WRD PSPBOOT 4 PORT firmware.
Latest: routertech-ar7wrd-pspboot-firmware-4ports-20110103.zip
Please read the instructions that come with the firmware files before you upgrade.
Note: a later version of the firmware may exist depending on the how up to date the RUC is.
The date-stamp may be superseded, but the rest of the filename should be the same.
According to your current MTD values, you should be able to upgrade using a single firmware image.
hashir
Novice
Novice
Posts: 22
Joined: Thu Jan 13, 2011 11:46 pm

Re: Aztech DSL 605EW (Single Antenna)

Post by hashir » Mon Feb 14, 2011 4:41 pm

setenv BUILD_OPS 0x301
setenv bootloaderVersion 1.4.0.4
setenv ProductID AR7WRD
setenv HWRevision Unknown
setenv SerialNumber none
setenv IPA 192.168.1.1
setenv MAC_PORT 0
setenv MEMSZ 0x01000000
setenv FLASHSZ 0x00400000
setenv MODETTY0 9600,n,8,1,hw
setenv MODETTY1 9600,n,8,1,hw
setenv CPUFREQ 211968000
setenv MIPSFREQ 211968000
setenv SYSFREQ 105984000
setenv BOOTCFG m:f:"mtd1"
setenv PROMPT (psbl)
setenv mtd0 0x900af000,0x90400000
setenv mtd1 0x90020090,0x900af000
setenv mtd2 0x90000000,0x90010000
setenv mtd3 0x90010000,0x90020000
setenv mtd4 0x90020000,0x90400000
setenv autopvc_enable 1
setenv pppoe_relay_enabled 1
setenv StaticBuffer 384
setenv DSL_BIT_TMODE 1
setenv sar_ipacemax 6
setenv DSL_UPG_DONE 1
setenv vcc_encaps0 0.0
setenv vcc_encaps1 0.0
setenv vcc_encaps2 0.0
setenv vcc_encaps3 0.0
setenv vcc_encaps4 0.0
setenv vcc_encaps5 0.0
setenv vcc_encaps6 0.0
setenv vcc_encaps7 0.0
setenv usb_vid 0x0451
setenv usb_pid 0x6060
setenv HWA_RNDIS 00:E0:A6:66:41:EB
setenv HWA_HRNDIS 00:E0:A6:66:41:E1
setenv connection0-mac 00-90-1a-42-fe-d5
setenv NVS_TFTP_LOAD 0
setenv no_auto_vlynq 1
setenv vlynq_polarity high
setenv WLAN_HWADDR0 00:12:0E:75:00:7F
setenv wan_br_mac 00:12:0E:75:00:7F
setenv WLAN_HWADDR1 02:30:1A:75:00:7F
setenv WLAN_HWADDR2 02:30:2A:75:00:7F
setenv WLAN_HWADDR3 02:30:3A:75:00:7F
setenv WLAN_EEPROM0 021156041B06001200000601095612000000010D56A9000000026D547F00750E
setenv WLAN_EEPROM1 12000000013984000100000101854C1068900105850600100001298507000000
setenv WLAN_EEPROM2 01C1850000300001C585000000000111850000FFFF0115850000F0FF01A58500
setenv WLAN_EEPROM3 8000000109850000800201010C03000000012184000000800181851D00030001
setenv WLAN_EEPROM4 55090100000001E5580200000001F1580800000001D5581000000001B1580400
setenv WLAN_EEPROM5 0000000000000000000C00C300FE0008011401260144014D014F0165019F01AF
setenv WLAN_EEPROM6 01B70101390000110004010101000501060002010201021E000A000205020411
setenv WLAN_EEPROM7 2244030610203031324004095449204143583130300507544920546573740108
setenv WLAN_EEPROM8 0D150EFD9D5C014F0502000036006D00A600E5000404441016004510F903185A
setenv WLAN_EEPROM9 4000145A2000020E0801E6000A0188026E00A30185095000F9000A01C1026E00
setenv WLAN_EEPROM10 A10185090107100000400000010000050400010100000000FFFFFFFFFDFDFDFD
setenv WLAN_EEPROM11 FBF4F4F4F40E0409090909090909090909090909090909090909090909090909
setenv WLAN_EEPROM12 090909090909090909090909090909090909090909090909090909090909090E
setenv WLAN_EEPROM13 0100000000000000000000000000000302A318A3180700012000000000000000
setenv IPA_SVR 192.168.1.2
User avatar
thechief
RouterTech Team
RouterTech Team
Posts: 12066
Joined: Wed Feb 01, 2006 10:22 pm
Location: England, the Centre of Africa
Contact:

Re: Aztech DSL 605EW (Single Antenna)

Post by thechief » Mon Feb 14, 2011 5:00 pm

Where is WLAN_EEPROM14 ?
The Chief: :afro: Be sure to read the Firmware FAQ and do a Forum Search before posting!
No support via PM. Ask all questions on the open forum.
hashir
Novice
Novice
Posts: 22
Joined: Thu Jan 13, 2011 11:46 pm

Re: Aztech DSL 605EW (Single Antenna)

Post by hashir » Mon Feb 14, 2011 5:16 pm

Let me run the ENVironment which you sent yesterday and I will let u know..
hashir
Novice
Novice
Posts: 22
Joined: Thu Jan 13, 2011 11:46 pm

Re: Aztech DSL 605EW (Single Antenna)

Post by hashir » Mon Feb 14, 2011 6:06 pm

setenv WLAN_EEPROM14 - this gives error. remainig all values are set.
User avatar
thechief
RouterTech Team
RouterTech Team
Posts: 12066
Joined: Wed Feb 01, 2006 10:22 pm
Location: England, the Centre of Africa
Contact:

Re: Aztech DSL 605EW (Single Antenna)

Post by thechief » Mon Feb 14, 2011 6:38 pm

Well, your wireless will not work without all the EEPROM variables. It is possible that the router's environment is fragmented, and that is why you can't set that variable. Or there may be another problem.

The long and short of it is that your current firmware will apparently not do the job. You are left with the choices of [1] living with no wireless, or [2] changing your firmware to RouterTech, defragmenting your environment, and then trying to reconstruct the environment variables again.
The Chief: :afro: Be sure to read the Firmware FAQ and do a Forum Search before posting!
No support via PM. Ask all questions on the open forum.
hashir
Novice
Novice
Posts: 22
Joined: Thu Jan 13, 2011 11:46 pm

Re: Aztech DSL 605EW (Single Antenna)

Post by hashir » Mon Feb 14, 2011 6:56 pm

I am going with the second..
hashir
Novice
Novice
Posts: 22
Joined: Thu Jan 13, 2011 11:46 pm

Re: Aztech DSL 605EW (Single Antenna)

Post by hashir » Mon Feb 14, 2011 6:58 pm

routertech-ar7wrd-pspboot-firmware-4ports-20110103.zip

Router update checked recommended this firmware.Shall I go with that.
Post Reply